Kernel driver not installed (rc=-1908) Getting Errors in macOS Big Sur 11.0.1

MacosVirtualboxMacos Big-Sur

Macos Problem Overview


I just want to work with VirtualBox but now I am getting this type of error.

I could not find a proper solution.

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

enter image description here

Macos Solutions


Solution 1 - Macos

MAC with BIG SUR -- Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where the error is:

suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Download and install the latest VirtualBox 6.1.18 or higher. And then follow the below steps to resolve.

Step 1 - run:

sudo kextload -b org.virtualbox.kext.VBoxDrv

Step 2: Go into System Preferences->Security & Privacy

Step 3: Unlock the security center

Step 4: Approve the software by Oracle

Step 5:

sudo kextload -b org.virtualbox.kext.VBoxNetFlt
sudo kextload -b org.virtualbox.kext.VBoxNetAdp
sudo kextload -b org.virtualbox.kext.VBoxUSB

Step 6: Reboot

Solution 2 - Macos

Registering the .kext directly via terminal solved this issue for me.

sudo kmutil load -p '/Library/Application Support/VirtualBox/VBoxDrv.kext'

There should be a prompt in System Preferences to allow the kernel, which will require a reboot.

Reboot and run command cd ˜/Homestead && vagrant up

Solution 3 - Macos

Big Sur disables the VirtualBox kernel extensions as part of the installation process. You can verify this by running:

kextstat | grep -v com.apple

If the kernel extensions are installed, you will see something like this:

Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
  184    3 0xffffff7fa232d000 0xb2000    0xb2000    org.virtualbox.kext.VBoxDrv (6.1.18) 9C1C33DF-8061-30A2-9266-C9284816A6A2 <8 6 5 3 1>
  187    0 0xffffff7fa240a000 0x5000     0x5000     org.virtualbox.kext.VBoxUSB (6.1.18) 51E577B4-43B6-359F-B817-9C63A69E7943 <186 184 62 8 6 5 3 1>
  188    0 0xffffff7fa2405000 0x4000     0x4000     org.virtualbox.kext.VBoxNetFlt (6.1.18) 96E530DE-E34D-3447-89A5-FCF6646AE47E <184 8 6 5 3 1>
  189    0 0xffffff7fa23ff000 0x2000     0x2000     org.virtualbox.kext.VBoxNetAdp (6.1.18) 63EFABA5-3341-3BEB-B47A-AAFCDD7312A5 <184 6 5 1>

If you don't see the extensions loaded, the easier fix is to delete your current VirtualBox app, download and install the lastest version and then go the Security & Privacy System Preferences Pane. You should see a message that some applications require a restart to work correctly.

Restart your Mac and VirtualBox should now work. You can re-run the kexstat command just to be sure the extensions were loaded.

Solution 4 - Macos

Here is how I solved the issue on MAC with MONTEREY

Update 09 december 2021 : installing the latest version (VirtualBox-6.1.30-148432-OSX.dmg when updating this post) completely solve the issue on my machine

Initial post :

  1. Download the latest installer of VirtualBox (VirtualBox-6.1.28-147628-OSX.dmg when writing this post)
  2. Launch the installer
  3. Double click on the file VirtualBox_Uninstall.tool in order to uninstall VirtualBox
  4. Reboot
  5. Reinstall VirtualBox

Solution 5 - Macos

I also got the same error while trying to run Windows 10 on macOS Big Sur 11.6, but I was easily able to fix the issue by navigating to System Preferences > Security & Privacy. There, under allow apps downloaded from section I found something like Oracle wants to install additional updates, and I gave permission. My Win 10 VM started to work. I hope this help.

Solution 6 - Macos

Solution worked for Big Sur (no need to delete anything):

  1. Update VirtualBox

  2. Install VirtualBox Extension Pack https://www.virtualbox.org/wiki/Downloads

  3. Settings -> Security -> General settings -> Unlock settings

  4. On "General settings" form turn allow application usage checkbox from "App Store and others..." to "App Store" and back to "App Store and others..." (to make sure Mac recognised the changes made before on steps 1-2)

  5. Go to "Additional settings" ("General settings" form button right after application usage checkbox), system will show Applications changes made before (steps 1-2), push "Ok" and system will ask for reboot

  6. After reboot VirtualBox will work

Solution 7 - Macos

after googling for few days and no solution worked for me on macos

I run the below commands

sudo kextload -b org.virtualbox.kext.VBoxDrv
sudo kextload -b org.virtualbox.kext.VBoxNetFlt
sudo kextload -b org.virtualbox.kext.VBoxNetAdp
sudo kextload -b org.virtualbox.kext.VBoxUSB

then go to "https://www.virtualbox.org/wiki/Downloads" and download "VirtualBox 6.1.30 Oracle VM VirtualBox Extension Pack" all platform

then open your virutalbox preferences --> choose extension --> and add the extension you just downloaded and eveything will be ok

Solution 8 - Macos

Another restart of the system solved my problem as I was already at the most current version of virtualbox. My macOS upgrade was from Big Sur 11.6.1 to 11.6.4.

Solution 9 - Macos

None of the methods here worked for me, the option to approve the driver in System Preferences / Security & Privacy never appeared.

The only way I could get to approve the extension was rebooting in recovery mode, and then giving consent to the Oracle Developr ID running in the Terminal the following command:

spctl kext-consent add VB5E2TV963

Then after a reboot, I could approve the driver and VirtualBox works just fine. Tested in Monterey 12.3.1

Full credits to this site: https://appuals.com/kernal-driver-not-installed-rc-1908-error-mac/

Solution 10 - Macos

I had face this issue before and I tried all the threads in this question and doesn't work, then I tried to add the iso file from the setting tab like shown in screenshots, and it worked well.

VirtualBox kernel error

VirtualBox kernel error

Attributions

All content for this solution is sourced from the original question on Stackoverflow.

The content on this page is licensed under the Attribution-ShareAlike 4.0 International (CC BY-SA 4.0) license.

Content TypeOriginal AuthorOriginal Content on Stackoverflow
QuestionShibaji DebnathView Question on Stackoverflow
Solution 1 - MacosGopiKarthi AndroidView Answer on Stackoverflow
Solution 2 - MacosSohail AhmedView Answer on Stackoverflow
Solution 3 - MacosGene Z. RaganView Answer on Stackoverflow
Solution 4 - MacosMoussaView Answer on Stackoverflow
Solution 5 - MacosaakardhakalView Answer on Stackoverflow
Solution 6 - MacosVladimir GolskiyView Answer on Stackoverflow
Solution 7 - MacosAhmed Taha HagagView Answer on Stackoverflow
Solution 8 - MacosFrankSView Answer on Stackoverflow
Solution 9 - MacosNicolás Alejandro MéndezView Answer on Stackoverflow
Solution 10 - MacosmedxoneView Answer on Stackoverflow