How to install Guest addition in Mac OS as guest and Windows machine as host

Virtual MachineVirtualbox

Virtual Machine Problem Overview


I am trying to copy contents from my host machine to a guest machine, but for copying I need to install the Guest additions disk.

Or there is there another way to access host machine content on the guest machine or vice-versa?

Virtual Machine Solutions


Solution 1 - Virtual Machine

Guest Additions are available for MacOS starting with VirtualBox 6.0.

Installing:

  1. Boot & login into your guest macOS.
  2. In VirtualBox UI, use menu Devices | Insert Guest Additions CD image...
  3. CD will appear on your macOS desktop, open it.
  4. Run VBoxDarwinAdditions.pkg.
  5. Go through installer, it's mostly about clicking Next.
  6. At some step, macOS will be asking about permissions for Oracle. Click the button to go to System Preferences and allow it.
  7. If you forgot/misclicked in step 6, go to macOS System Preferences | Security & Privacy | General. In the bottom, there will be a question to allow permissions for Oracle. Allow it.

Troubleshooting

  1. macOS 10.15 introduced new code signing requirements; Guest additions installation will fail. However, if you reboot and apply step 7 from list above, shared clipboard will still work.
  2. VirtualBox < 6.0.12 has a bug where Guest Additions service doesn't start. Use newer VirtualBox.

Solution 2 - Virtual Machine

  1. In the guest Mac, open the Terminal and go for a reboot on the Recovery partition
sudo nvram "recovery-boot-mode=unused"
sudo reboot
  1. Now you're in Recovery mode, enter the Terminal and do:
csrutil disable
spctl kext-consent add VB5E2TV963
nvram -d recovery-boot-mode
reboot
  1. Back in "normal" mode, open the Terminal, and do:
sudo mount -uw /
sudo chown :admin /System/Library/Extensions/
sudo chmod 775 /System/Library/Extensions/
  1. Run the Guest Additions installer and go through the end (in principle, it goes through successfully)

  2. Now in the terminal, do:

sudo chown :wheel /System/Library/Extensions/
sudo chmod 755 /System/Library/Extensions/
sudo nvram "recovery-boot-mode=unused"
sudo reboot
  1. Again in Recovery mode, go into the Terminal and do:
csrutil enable
nvram -d recovery-boot-mode
reboot

You should be set.

Solution 3 - Virtual Machine

Guest additions are not available for Mac OS X. You can get features like clipboard sync and shared folders by using VNC and SMB. Here's my answer on a similar question.

Solution 4 - Virtual Machine

You can use SSH and SFTP as suggested here.

  1. In the Guest OS (Mac OS X), open System Preferences > Sharing, then activate Remote Login; note the ip address specified in the Remote Login instructions, e.g. ssh [email protected]
  2. In VirtualBox, open Devices > Network > Network Settings > Advanced > Port Forwarding and specify Host IP = 127.0.0.1, Host Port 2222, Guest IP 10.0.2.15, Guest Port 22
  3. On the Host OS, run the following command sftp -P 2222 [email protected]; if you prefer a graphical interface, you can use FileZilla

Replace user and 10.0.2.15 with the appropriate values relevant to your configuration.

Solution 5 - Virtual Machine

I've the same problem, and by the "trial and error" method I have the steps to install the guest additions on a MacOS guest:

  1. insert the guest additions cd
  2. open the cd on file manager
  3. double click on VBoxDarwinAdditions.pkg
  4. the installer opens, then click contine
  5. next screen to set location of installed files, only press install
  6. your password can be asked a couple of time while installing, write it and continue
  7. this is the tricky part, on my installation, macos show an message about the driver created by oracle won't be installed because a security issue, it has the option to enable it, so click on the button to open security screen and click on the allow button next to the oracle software listed at bottom of the security settings window, it will ask your password again. Meanwhile the pkg installer continued as if it has permissions and will say "install finished", but I don't believe it so, once I unlocked the oracle drivers installations I repeat the whole process from step 3, and in the second round all installs without asking more than the first password to install.

And it is done!

Solution 6 - Virtual Machine

Above, someone gave a hint:

At some step, macOS will be asking about permissions for Oracle. Click the button to go to System Preferences and allow it. If you forgot/misclicked in step 6, go to macOS System Preferences | Security & Privacy | General. In the bottom, there will be a question to allow permissions for Oracle. Allow it.

It took me a couple of hours but I did finally find what he was talking about - it's actually in the bottom of the Mac - click on the gear icon and you'll find it eventually.

Solution 7 - Virtual Machine

You need to update your virtualbox sw. On new version, there is VBoxDarwinAdditions.pkg included in a additions iso image, in older versions is missing.

Solution 8 - Virtual Machine

you can do it from the windows 10 terminal

step 1: open CMD in administrator mode

step 2 paste this open CMD cd "C:\Program Files\Oracle\Virtualbox"

step 3: paste this command in the open CMD, you must indicate the name you have in VirtualBox

VBoxManage setextradata "Virtual machine name" VBoxInternal2/EfiGraphicsResolution X

Example:

VBoxManage setextradata "Mac OS Sierra" VBoxInternal2/EfiGraphicsResolution 1280x720

Solution 9 - Virtual Machine

Before you start, close VirtualBox! After those manipulations start VB as Administrator!


  1. Run CMD as Administrator
  2. Use lines below one by one:
  • cd "C:\Program Files\Oracle\Virtualbox"
  • VBoxManage setextradata “macOS_Catalina” VBoxInternal2/EfiGraphicsResolution 1920x1080

Screen Resolutions: 1280x720, 1920x1080, 2048x1080, 2560x1440, 3840x2160, 1280x800, 1280x1024, 1440x900, 1600x900

Description:

  • macOS_Catalina - insert your VB machine name.

  • 1920x1080 - put here your Screen Resolution.

Cheers!

Solution 10 - Virtual Machine

Have you tried https://www.virtualbox.org/manual/ch04.html which has step-by-step instructions to help you?

  1. Make your VM bi-directional for Clipboard and Drag & Drop
  2. Share folders from your host to the guest VM too.

Attributions

All content for this solution is sourced from the original question on Stackoverflow.

The content on this page is licensed under the Attribution-ShareAlike 4.0 International (CC BY-SA 4.0) license.

Content TypeOriginal AuthorOriginal Content on Stackoverflow
QuestionRakesh ChaudhariView Question on Stackoverflow
Solution 1 - Virtual MachineCodeguardView Answer on Stackoverflow
Solution 2 - Virtual MachinelaiView Answer on Stackoverflow
Solution 3 - Virtual MachineTomTascheView Answer on Stackoverflow
Solution 4 - Virtual MachineRoy Hyunjin HanView Answer on Stackoverflow
Solution 5 - Virtual MachineSergio EView Answer on Stackoverflow
Solution 6 - Virtual MachineMee SiphhtView Answer on Stackoverflow
Solution 7 - Virtual MachineinventoradoView Answer on Stackoverflow
Solution 8 - Virtual MachineAN GermanView Answer on Stackoverflow
Solution 9 - Virtual MachinerediffusionView Answer on Stackoverflow
Solution 10 - Virtual Machineuser1548875View Answer on Stackoverflow