count vs length vs size in a collection

CollectionsNaming ConventionsTerminologySemantics

Collections Problem Overview


From using a number of programming languages and libraries I have noticed various terms used for the total number of elements in a collection.

The most common seem to be length, count, and size.

eg.

array.length
vector.size()
collection.count

Is there any preferred term to be used? Does it depend on what type of collection it is? ie. mutable/immutable

Is there a preference for it being a property instead of a method?

Collections Solutions


Solution 1 - Collections

Length() tends to refer to contiguous elements - a string has a length for example.

Count() tends to refer to the number of elements in a looser collection.

Size() tends to refer to the size of the collection, often this can be different from the length in cases like vectors (or strings), there may be 10 characters in a string, but storage is reserved for 20. It also may refer to number of elements - check source/documentation.

Capacity() - used to specifically refer to allocated space in collection and not number of valid elements in it. If type has both "capacity" and "size" defined then "size" usually refers to number of actual elements.

I think the main point is down to human language and idioms, the size of a string doesn't seem very obvious, whilst the length of a set is equally confusing even though they might be used to refer to the same thing (number of elements) in a collection of data.

Solution 2 - Collections

FWIW (and that's vanishingly close to nothing), I prefer 'Count' because it seems to indicate that it's going to return the number of elements/items in the collection pretty unambigously.

When faced with the terms 'Length' or 'Size' I'm often left wondering for a moment (or even being forced to re-read documentation) whether the damn thing is going to tell me how many elements are in the colection or how many bytes the collection is consuming. This is particularly true for collections that are intended to be contingous like arrays or strings.

But no one who was responsible for the naming conventions used by the Java, BCL/.Net, or C/C++ standard frameworks/libraries bothered to ask me, so you're all stuck with whatever they came up with.

If only I were much smarter than I am and was named Bjarne, all of you might be spared the misery...

Of course, back in the real world, you should try to stick with whatever naming convention is used by the language/platform you're using (eg., size() in C++). Not that this seems to help you with your Array.Length dilemma.

Solution 3 - Collections

The terms are somewhat interchangeably, though in some situations I would prefer one over another. Usually you can get the best usage if you think about How would you describe the length/size/count of this element verbally to another person?

length() implies that the element has a length. A string has a length. You say "a string is 20 characters long", right? So it has a length.

size() implies that the element has a size. E.g. a file has a size. You say "this file has a size of 2 MB", right? So it has a size.

That said, a string can also have a size, but I'd expect something else here. E.g. a UTF-16 string may have a length of 100 characters, but as every character is composed out of two byte, I'd expect size to be 200.

count() is very unusual. Objective-C uses count for the number of elements in an array. One might argue if an array has a length (as in Java), has a size (as in most other languages) or has a count. However, size might again be the size in byte (if the array items are 32 bit int, each item is 4 byte) and length... I wouldn't say "an array is 20 elements long", that sounds rather odd to me. I'd say "an array has 20 elements". I'm not sure if count expresses that very well, but I think count is here a short form for elementCount() and that again makes much more sense for an array than length() or size().

If you create own objects/elements in a programming language, it's best to use whatever other similar elements use, since programmers are used to accessing the desired property using that term.

Solution 4 - Collections

Count I think is the most obvious term to use if you're looking for the number of items in a collection. That should even be obvious to new programmers who haven't become particularly attached to a given language yet.

And it should be a property as that's what it is: a description (aka property) of the collection. A method would imply that it has to do something to the collection to get the number of items and that just seems unintuitive.

Solution 5 - Collections

Hmm...I would not use size. Because this might be confused with size in bytes. Length - could make some sense for arrays, as long as they are supposed to use consequent bytes of memory. Though...length...in what? Count is clear. How many elements. I would use count.

About property/method, I would use property to mark it's fast, and method to mark it's slow.

And, the most important - I would stick to the standards of the languages/libraries you are using.

Solution 6 - Collections

Adding to @gbjbaanb's answer...

If "property" implies public access to the value, I would say that "method" is preferred simply to provide encapsulation and to hide the implementation.

You might change you mind about how to count elements or how you maintain that count. If it is a property, you're stuck - if it is acessed via a method, you can change the underlying implementation without impacting users of the collection.

Solution 7 - Collections

In Elixir there is actually a clear naming scheme associated with it across types in the language.

> When “counting” the number of elements in a data structure, Elixir > also abides by a simple rule: the function is named size if the > operation is in constant time (i.e. the value is pre-calculated) or > length if the operation is linear (i.e. calculating the length gets > slower as the input grows).

Solution 8 - Collections

To me, this is a little like asking whether "foreach" is better than "for each". It just depends on the language/framework.

Solution 9 - Collections

I would say that it depends on particular language that you are using and classes. For example in c# if you are using Array you have Property Length, if you have something that inherits from IEnumerable you have extension Method Count(), but it is not fast. And if you inherited from ICollection you have Property Count.

Solution 10 - Collections

Kotlin answer

from _Collections.kt

/**
 * Returns the number of elements in this collection.
 */
@kotlin.internal.InlineOnly
public inline fun <T> Collection<T>.count(): Int {
    return size
}

Attributions

All content for this solution is sourced from the original question on Stackoverflow.

The content on this page is licensed under the Attribution-ShareAlike 4.0 International (CC BY-SA 4.0) license.

Content TypeOriginal AuthorOriginal Content on Stackoverflow
QuestionmolassesView Question on Stackoverflow
Solution 1 - CollectionsgbjbaanbView Answer on Stackoverflow
Solution 2 - CollectionsMichael BurrView Answer on Stackoverflow
Solution 3 - CollectionsMeckiView Answer on Stackoverflow
Solution 4 - CollectionsCorinView Answer on Stackoverflow
Solution 5 - CollectionsPaul KapustinView Answer on Stackoverflow
Solution 6 - CollectionsKen GentleView Answer on Stackoverflow
Solution 7 - CollectionsbrightballView Answer on Stackoverflow
Solution 8 - CollectionsEBGreenView Answer on Stackoverflow
Solution 9 - CollectionsAlexandrView Answer on Stackoverflow
Solution 10 - CollectionsKochchyView Answer on Stackoverflow